import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0|\\+84)[1-9][0-9]{8,9}$";
final String string = "0123450679\n"
+ "0103450679\n"
+ "+84103450679\n"
+ "01234567899\n"
+ "0000000000\n"
+ "0\n"
+ "012324\n"
+ "12345\n"
+ "0123456789000000\n"
+ "0012345678\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}