using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(Campaign A|Campaign B).*$";
string input = @"In this block of text, our expression will only match a line if the expression contains either Campaign A or Campaign B.
This line will be filtered out.
This includes Campaign A
Campaign D
Campaign B
This is another random campaign we don't want
We want to include Campaign A and Campaign B
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}