const regex = /^.*(Campaign A|Campaign B).*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(Campaign A|Campaign B).*$', 'gmi')
const str = `In this block of text, our expression will only match a line if the expression contains either Campaign A or Campaign B.
This line will be filtered out.
This includes Campaign A
Campaign D
Campaign B
This is another random campaign we don't want
We want to include Campaign A and Campaign B
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}