// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^.*(Campaign A|Campaign B).*$").unwrap();
let string = "In this block of text, our expression will only match a line if the expression contains either Campaign A or Campaign B.
This line will be filtered out.
This includes Campaign A
Campaign D
Campaign B
This is another random campaign we don't want
We want to include Campaign A and Campaign B
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}