import re
regex = re.compile(r"^.*(Campaign A|Campaign B).*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("In this block of text, our expression will only match a line if the expression contains either Campaign A or Campaign B.\n\n"
"This line will be filtered out.\n"
"This includes Campaign A\n"
"Campaign D\n"
"Campaign B\n"
"This is another random campaign we don't want\n"
"We want to include Campaign A and Campaign B\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")