import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(Campaign A|Campaign B).*$";
final String string = "In this block of text, our expression will only match a line if the expression contains either Campaign A or Campaign B.\n\n"
+ "This line will be filtered out.\n"
+ "This includes Campaign A\n"
+ "Campaign D\n"
+ "Campaign B\n"
+ "This is another random campaign we don't want\n"
+ "We want to include Campaign A and Campaign B\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}