# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({|"|,)([ ]{2,})/$1/gm;t' <<< "{ \"1\": \"This is a string\", \"AnInt\": 123, \"3\": [6, 9, 429]}"