re = /({|"|,)([ ]{2,})/m
str = '{ "1": "This is a string", "AnInt": 123, "3": [6, 9, 429]}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result