// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)({|"|,)([ ]{2,})"#).unwrap();
let string = "{ \"1\": \"This is a string\", \"AnInt\": 123, \"3\": [6, 9, 429]}";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}