import re
regex = re.compile(r"({|\"|,)([ ]{2,})", flags=re.MULTILINE)
test_str = "{ \"1\": \"This is a string\", \"AnInt\": 123, \"3\": [6, 9, 429]}"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)