$re = '/({|"|,)([ ]{2,})/m';
$str = '{ "1": "This is a string", "AnInt": 123, "3": [6, 9, 429]}';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;