using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({|""|,)([ ]{2,})";
string substitution = @"$1";
string input = @"{ ""1"": ""This is a string"", ""AnInt"": 123, ""3"": [6, 9, 429]}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}