import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(d+\\s*+|d+\\s*+([\\Q!@#$%^&*()_+-\\E]|(§|&)[0-9A-FK-OR]|(§|&))+\\s*+)(u+\\s*+|([\\Q!@#$%^&*()_+-\\E]|(§|&)[0-9A-FK-OR]|(§|&))+\\s*+u+\\s*+)(c+\\s*+|([\\Q!@#$%^&*()_+-\\E]|(§|&)[0-9A-FK-OR]|(§|&))+\\s*+c+\\s*+)(k+|([\\Q!@#$%^&*()_+-\\E]|(§|&)[0-9A-FK-OR]|(§|&))+k)";
final String string = "duck\n"
+ "d uck\n"
+ "duuuuuuuck\n\n"
+ "d@#*$&%@#(*$&@#(*$&@#(*$!@()*#!@%uck\n\n"
+ "d\n"
+ "u\n"
+ "c\n"
+ "k\n\n"
+ "d§bu§bc§bk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}