use strict;
my $str = 'duck
d uck
duuuuuuuck
d@#*$&%@#(*$&@#(*$&@#(*$!@()*#!@%uck
d
u
c
k
d§bu§bc§bk';
my $regex = qr/(?i)(d+\s*+|d+\s*+([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+)(u+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+u+\s*+)(c+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+c+\s*+)(k+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+k)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}