re = /(?i)(d+\s*+|d+\s*+([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+)(u+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+u+\s*+)(c+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+c+\s*+)(k+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+k)/m
str = 'duck
d uck
duuuuuuuck
d@#*$&%@#(*$&@#(*$&@#(*$!@()*#!@%uck
d
u
c
k
d§bu§bc§bk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end