const regex = /(?i)(d+\s*+|d+\s*+([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+)(u+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+u+\s*+)(c+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+c+\s*+)(k+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+k)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(d+\\s*+|d+\\s*+([\\Q!@#$%^&*()_+-\\E]|(§|&)[0-9A-FK-OR]|(§|&))+\\s*+)(u+\\s*+|([\\Q!@#$%^&*()_+-\\E]|(§|&)[0-9A-FK-OR]|(§|&))+\\s*+u+\\s*+)(c+\\s*+|([\\Q!@#$%^&*()_+-\\E]|(§|&)[0-9A-FK-OR]|(§|&))+\\s*+c+\\s*+)(k+|([\\Q!@#$%^&*()_+-\\E]|(§|&)[0-9A-FK-OR]|(§|&))+k)', 'gm')
const str = `duck
d uck
duuuuuuuck
d@#*\$&%@#(*\$&@#(*\$&@#(*\$!@()*#!@%uck
d
u
c
k
d§bu§bc§bk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}