import Foundation
let pattern = ##"(?i)(d+\s*+|d+\s*+([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+)(u+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+u+\s*+)(c+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+c+\s*+)(k+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+k)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
duck
d uck
duuuuuuuck
d@#*$&%@#(*$&@#(*$&@#(*$!@()*#!@%uck
d
u
c
k
d§bu§bc§bk
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)