$re = '/(?i)(d+\s*+|d+\s*+([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+)(u+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+u+\s*+)(c+\s*+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+\s*+c+\s*+)(k+|([\Q!@#$%^&*()_+-\E]|(§|&)[0-9A-FK-OR]|(§|&))+k)/m';
$str = 'duck
d uck
duuuuuuuck
d@#*$&%@#(*$&@#(*$&@#(*$!@()*#!@%uck
d
u
c
k
d§bu§bc§bk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);