#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+ \w+\((?:(.|\n)*)\))\s*^paragraph_b"
Local $sString = "some random texts (100+ lines)" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
"" & @CRLF & _
"paragraph_a A_story( " & @CRLF & _
"..." & @CRLF & _
"some random texts" & @CRLF & _
"..." & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"paragraph_b different_story(" & @CRLF & _
"..." & @CRLF & _
"some random texts" & @CRLF & _
"..." & @CRLF & _
")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")