import re
regex = re.compile(r"^(\w+ \w+\((?:(.|\n)*)\))\s*^paragraph_b", flags=re.MULTILINE)
test_str = ("some random texts (100+ lines)\n\n"
"...\n\n"
"paragraph_a A_story( \n"
"...\n"
"some random texts\n"
"...\n"
")\n\n"
"paragraph_b different_story(\n"
"...\n"
"some random texts\n"
"...\n"
")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")