// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+ \w+\((?:(.|\n)*)\))\s*^paragraph_b").unwrap();
let string = "some random texts (100+ lines)
...
paragraph_a A_story(
...
some random texts
...
)
paragraph_b different_story(
...
some random texts
...
)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}