import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+ \\w+\\((?:(.|\\n)*)\\))\\s*^paragraph_b";
final String string = "some random texts (100+ lines)\n\n"
+ "...\n\n"
+ "paragraph_a A_story( \n"
+ "...\n"
+ "some random texts\n"
+ "...\n"
+ ")\n\n"
+ "paragraph_b different_story(\n"
+ "...\n"
+ "some random texts\n"
+ "...\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}