$re = '/^(\w+ \w+\((?:(.|\n)*)\))\s*^paragraph_b/m';
$str = 'some random texts (100+ lines)
...
paragraph_a A_story(
...
some random texts
...
)
paragraph_b different_story(
...
some random texts
...
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);