re = /^(\w+ \w+\((?:(.|\n)*)\))\s*^paragraph_b/m
str = 'some random texts (100+ lines)
...
paragraph_a A_story(
...
some random texts
...
)
paragraph_b different_story(
...
some random texts
...
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end