using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s+|(\s)\s+|(\.)\.|(')'|[^ a-z'.]+";
string substitution = @"$1$2$3";
string input = @" ..Some.. ''string'' ";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}