$re = '/^\s+|(\s)\s+|(\.)\.|(\')\'|[^ a-z\'.]+/i';
$str = ' ..Some.. \'\'string\'\' ';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;