// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^\s+|(\s)\s+|(\.)\.|(')'|[^ a-z'.]+").unwrap();
let string = " ..Some.. ''string'' ";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}