package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^\s+|(\s)\s+|(\.)\.|(')'|[^ a-z'.]+`)
var str = ` ..Some.. ''string'' `
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}