use strict;
my $str = ' ..Some.. \'\'string\'\' ';
my $regex = qr/^\s+|(\s)\s+|(\.)\.|(')'|[^ a-z'.]+/ip;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";