const regex = /^\s+|(\s)\s+|(\.)\.|(')'|[^ a-z'.]+/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+|(\\s)\\s+|(\\.)\\.|(\')\'|[^ a-z\'.]+', 'gi')
const str = ` ..Some.. ''string'' `;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);