import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\moviles\\/)";
final String string = "/tag/moviles/cabalgada/page/108\n"
+ "/moviles/?q=sexo con criada&page=339\n"
+ "/tag/moviles/cabalgada/page/108\n"
+ "/tag/moviles/felacion/page/171\n"
+ "/tag/moviles/FamosasyFamosos\n"
+ "/tag/moviles/Frutas y Verduras/page/2\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}