#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/(?!.*\.google\..*search).*"
Local $sString = "https://www.google.com/search?newwindow=1&sxsrf=ALeKk02MzEfbUp3jO4Np" & @CRLF & _
"https://github.com/redis/redis-rb" & @CRLF & _
"https://web.whatsapp.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")