re = /https?:\/\/(?!.*\.google\..*search).*/m
str = 'https://www.google.com/search?newwindow=1&sxsrf=ALeKk02MzEfbUp3jO4Np
https://github.com/redis/redis-rb
https://web.whatsapp.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end