using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(?!.*\.google\..*search).*";
string input = @"https://www.google.com/search?newwindow=1&sxsrf=ALeKk02MzEfbUp3jO4Np
https://github.com/redis/redis-rb
https://web.whatsapp.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}