import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(?!.*\\.google\\..*search).*";
final String string = "https://www.google.com/search?newwindow=1&sxsrf=ALeKk02MzEfbUp3jO4Np\n"
+ "https://github.com/redis/redis-rb\n"
+ "https://web.whatsapp.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}