const regex = /https?:\/\/(?!.*\.google\..*search).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/(?!.*\\.google\\..*search).*', 'gm')
const str = `https://www.google.com/search?newwindow=1&sxsrf=ALeKk02MzEfbUp3jO4Np
https://github.com/redis/redis-rb
https://web.whatsapp.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}