$re = '/https?:\/\/(?!.*\.google\..*search).*/m';
$str = 'https://www.google.com/search?newwindow=1&sxsrf=ALeKk02MzEfbUp3jO4Np
https://github.com/redis/redis-rb
https://web.whatsapp.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);