#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^\n]+)\nCPF"
Local $sString = "ESTADO DE SANTA CATARINA" & @CRLF & _
"Contra-cheque individual" & @CRLF & _
"Administracao dos Pensionistas do IPREV" & @CRLF & _
"1505 - ADMINISTRACAO DOS PENSIONISTAS DO IPREV" & @CRLF & _
"CPF: 000.000.000-00" & @CRLF & _
"Matrícula: 0000000000" & @CRLF & _
"Inscrição: 00000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")