re = /([^\n]+)\nCPF/m
str = 'ESTADO DE SANTA CATARINA
Contra-cheque individual
Administracao dos Pensionistas do IPREV
1505 - ADMINISTRACAO DOS PENSIONISTAS DO IPREV
CPF: 000.000.000-00
Matrícula: 0000000000
Inscrição: 00000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end