$re = '/([^\n]+)\nCPF/m';
$str = 'ESTADO DE SANTA CATARINA
Contra-cheque individual
Administracao dos Pensionistas do IPREV
1505 - ADMINISTRACAO DOS PENSIONISTAS DO IPREV
CPF: 000.000.000-00
Matrícula: 0000000000
Inscrição: 00000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);