// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\n]+)\nCPF").unwrap();
let string = "ESTADO DE SANTA CATARINA
Contra-cheque individual
Administracao dos Pensionistas do IPREV
1505 - ADMINISTRACAO DOS PENSIONISTAS DO IPREV
CPF: 000.000.000-00
Matrícula: 0000000000
Inscrição: 00000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}