import Foundation
let pattern = #"([^\n]+)\nCPF"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ESTADO DE SANTA CATARINA
Contra-cheque individual
Administracao dos Pensionistas do IPREV
1505 - ADMINISTRACAO DOS PENSIONISTAS DO IPREV
CPF: 000.000.000-00
Matrícula: 0000000000
Inscrição: 00000000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)