import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\n]+)\\nCPF";
final String string = "ESTADO DE SANTA CATARINA\n"
+ "Contra-cheque individual\n"
+ "Administracao dos Pensionistas do IPREV\n"
+ "1505 - ADMINISTRACAO DOS PENSIONISTAS DO IPREV\n"
+ "CPF: 000.000.000-00\n"
+ "Matrícula: 0000000000\n"
+ "Inscrição: 00000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}