#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(NS[\d]{3,})"
Local $sString = "<div class="product-desc col-md-6"> <h1 class="product-title" id="productTitle" " & @CRLF & _
"itemprop="name">Шлем для крепления электродов ЭЭГ (взрослый)</h1><p>NS023211.007-02 " & @CRLF & _
"(размер 54-62), синий</p><p>NS023211-01 (размер 48-54), " & @CRLF & _
"зеленый</p><p>NS023211 размер 42-48), желтый</p></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")