// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(NS[\d]{3,})").unwrap();
let string = "<div class=\"product-desc col-md-6\"> <h1 class=\"product-title\" id=\"productTitle\"
itemprop=\"name\">Шлем для крепления электродов ЭЭГ (взрослый)</h1><p>NS023211.007-02
(размер 54-62), синий</p><p>NS023211-01 (размер 48-54),
зеленый</p><p>NS023211 размер 42-48), желтый</p></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}