const regex = /(NS[\d]{3,})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(NS[\\d]{3,})', 'g')
const str = `<div class="product-desc col-md-6"> <h1 class="product-title" id="productTitle"
itemprop="name">Шлем для крепления электродов ЭЭГ (взрослый)</h1><p>NS023211.007-02
(размер 54-62), синий</p><p>NS023211-01 (размер 48-54),
зеленый</p><p>NS023211 размер 42-48), желтый</p></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}