package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(NS[\d]{3,})`)
var str = `<div class="product-desc col-md-6"> <h1 class="product-title" id="productTitle"
itemprop="name">Шлем для крепления электродов ЭЭГ (взрослый)</h1><p>NS023211.007-02
(размер 54-62), синий</p><p>NS023211-01 (размер 48-54),
зеленый</p><p>NS023211 размер 42-48), желтый</p></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}