import re
regex = re.compile(r"(NS[\d]{3,})")
test_str = ("<div class=\"product-desc col-md-6\"> <h1 class=\"product-title\" id=\"productTitle\" \n"
"itemprop=\"name\">Шлем для крепления электродов ЭЭГ (взрослый)</h1><p>NS023211.007-02 \n"
"(размер 54-62), синий</p><p>NS023211-01 (размер 48-54), \n"
"зеленый</p><p>NS023211 размер 42-48), желтый</p></div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")