use strict;
my $str = '<div class="product-desc col-md-6"> <h1 class="product-title" id="productTitle"
itemprop="name">Шлем для крепления электродов ЭЭГ (взрослый)</h1><p>NS023211.007-02
(размер 54-62), синий</p><p>NS023211-01 (размер 48-54),
зеленый</p><p>NS023211 размер 42-48), желтый</p></div>';
my $regex = qr/(NS[\d]{3,})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}