#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]?\d(\.\d{1,2})?|100(\.0{1,2})?)$"
Local $sString = "1000" & @CRLF & _
"101" & @CRLF & _
"100.01" & @CRLF & _
"100.00" & @CRLF & _
"100.0" & @CRLF & _
"100" & @CRLF & _
"12.30" & @CRLF & _
"12.34" & @CRLF & _
"12.3" & @CRLF & _
"12" & @CRLF & _
"012" & @CRLF & _
"1.20" & @CRLF & _
"1.2" & @CRLF & _
"1" & @CRLF & _
"01.2" & @CRLF & _
"0.10" & @CRLF & _
"0.1" & @CRLF & _
".1" & @CRLF & _
"01" & @CRLF & _
"00" & @CRLF & _
"0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")